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   Test a Web page from another user account, another browser, and another computer 

   Verify that Active Scripting, ActiveX, and Java are not blocked 

   
Verify that your anti-virus program is not set to scan the Temporary Internet Files or Downloaded 
Program Files folders 
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   Turn off the features that you do not need 
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   Reconfigure the video card settings 

     Disable the "Show Window Contents While Dragging" option 

     Reduce the number of colors that Windows uses 
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     Turn off hardware acceleration 
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   Install the current version of Microsoft DirectX 
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SYMPTOMS 

A Web page may not display or work correctly, and you may receive an error message that is similar to 
any one of the following error messages:  
Problems with this Web page might prevent it from being displayed properly or functioning properly. In 
the future you can display this message by double-clicking the warning icon displayed in the Status Bar. 
If you click Show Details, error details that are similar to the following error details may appear:  
Line: 4 
Char: 1 
Error: Object doesn't support this property or method. 
Code: 0 
URL: http://Webserver/page.htm 
A Runtime Error has occured. 
Do you wish to Debug? 
Line: 4 
Error: Object doesn't support this property or method. 
The following warning message may also appear in the Microsoft Internet Explorer Status bar:  
Done, but with errors on page. 
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This issue occurs because the HTML source code for the Web page does not work correctly with client-side 
script such as Microsoft JScript or Visual Basic script. This problem may occur for any one or more of the 
following reasons:  

• A problem in the HTML source code of the Web page. 



• 
Active scripting , ActiveX controls or Java applets are blocked on your computer or network. Internet 
Explorer or another program, such as anti-virus programs or firewalls, can be configured to block Active 
scripting , ActiveX controls or Java applets 

• 
Anti-virus software is configured to scan your Temporary Internet Files or Downloaded Program Files 
folders. 

• The scripting engine on your computer is corrupt or outdated. 

• Internet-related folders on your computer are corrupt. 

• Your video card drivers are corrupt or outdated. 

• The DirectX component on your computer is corrupt or outdated. 

Note Server-side scripts such as Visual Basic scripts in Active Server Pages (ASP) run on a Web server. 
Script errors that occur because of server-side script failures do not produce error messages in Internet 
Explorer but may also create a Web page that does not display or work correctly. The troubleshooting 
information in this article applies to client-side script errors. Contact the administrator of the Web server if 
you suspect a problem with a server-side script.  
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RESOLUTION 

Use the troubleshooting methods that are described in this article in the order that they appear. When you 
finish a troubleshooting section, test to determine if the script error still occurs. If the issue is resolved, do 
not go to the next section. If the issue is not resolved, go to the next section.  
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Test a Web page from another user account, another browser, and another computer 

If the problem only occurs when you view one or two Web pages, view the pages from another user 
account, from another browser, or from another computer to determine whether the problem persists. If 
the script error persists, there may be a problem with the way the Web page is written. Contact the Web 
site administrator or content developer to inform them of the problem with the Web page. If the script 
error does not occur when you use the Web page from another user account, the problem may be caused 
by files or settings for your user profile. If the script error does not occur when you use the Web page 
from another browser or another computer, then continue troubleshooting.  
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Verify that Active Scripting, ActiveX, and Java are not blocked 

Verify that Internet Explorer or another program on your computer such as an anti-virus program or a 
firewall are not configured to block scripts, ActiveX controls, or Java applets. Active Scripting, ActiveX 
controls, and Java applets are turned off at the High security level in Internet Explorer. By default, 
Internet Explorer 6 and some versions of Internet Explorer 5.x use the High security level for the 
Restricted sites zone. By default, Microsoft Windows Server 2003 uses the High security level for both the 
Restricted sites zone and the Internet zone. To reset the Internet Explorer security settings for the current 
Web page, follow these steps:  

1. Start Internet Explorer. 

2. On the Tools menu, click Internet Options. 

3. In the Internet Options dialog box, click Security.

4. Click Default Level. 

5. Click OK. 

See the documentation for the anti-virus program or firewall that you are using to determine how to turn 
on scripting, ActiveX and Java applets.  
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Verify that your anti-virus program is not set to scan the Temporary Internet Files or 
Downloaded Program Files folders 



See the documentation for the anti-virus program that you are using to determine how to prevent the 
program from scanning the Temporary Internet Files and Downloaded Program Files folders.  
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Remove all the temporary Internet-related files 

Remove all the temporary Internet-related files from your computer. To do so, follow these steps:  

1. Start Internet Explorer. 

2. On the Tools menu, click Internet Options.  

3. Click the General tab. 

4. Under Temporary Internet files, click Settings. 

5. Click Delete Files. 

6. Click OK. 

7. Click Delete Cookies. 

8. Click OK. 

9. Under History, click Clear History, and then click Yes.

10. Click OK. 
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Update or repair the scripting engine 

To update the scripting engine for Internet Explorer on Microsoft Windows 98, Windows 98 Second Edition, 
Windows Millennium Edition, and Windows NT 4.0, download the latest scripting engine. To do so, visit the 
following Microsoft Web site:  
http://www.microsoft.com/downloads/details.aspx?FamilyId=0A8A18F6-249C-4A72-BFCF-
FC6AF26DC390&displaylang=en (http://www.microsoft.com/downloads/details.aspx?FamilyId=0A8A18F6-
249C-4A72-BFCF-FC6AF26DC390&displaylang=en) 
To update the scripting engine for Internet Explorer on Microsoft Windows 2000, download the latest 
scripting engine. To do so, visit the following Microsoft Web site:  
http://www.microsoft.com/downloads/details.aspx?FamilyId=C717D943-7E4B-4622-86EB-
95A22B832CAA&displaylang=en 
(http://www.microsoft.com/downloads/details.aspx?FamilyId=C717D943-7E4B-4622-86EB-
95A22B832CAA&displaylang=en) 
If you are running Microsoft Windows XP or Windows Server 2003, you are already running Windows 
Script 5.6. In this case, you may have to perform an in-place upgrade or repair of Windows to repair the 
scripting engines. 
 
For additional information about how to perform an in-place upgrade or repair of Windows, click the 
following article numbers to view the articles in the Microsoft Knowledge Base:  
816579 (http://support.microsoft.com/kb/816579/) How to perform an in-place upgrade of Windows 
Server 2003  
315341 (http://support.microsoft.com/kb/315341/) How to perform an in-place upgrade (reinstallation) of 
Windows XP  
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Turn off the features that you do not need 

Smooth Scrolling 

To turn off the Smooth Scrolling feature, follow the steps for your version of Internet Explorer. 
 
For Internet Explorer 4.x, follow these steps:  

1. Start Internet Explorer, and then click Internet Options on the View menu.

2. On the Advanced tab, clear the Use Smooth Scrolling check box. 

3. Click OK, and then quit Internet Explorer. 



For Internet Explorer 5.x and Internet Explorer 6, follow these steps:  

1. On the Tools menu, click Internet Options. 

2. On the Advanced tab, clear the Use Smooth Scrolling check box.

3. Click OK, and then quit Internet Explorer. 
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Reconfigure the video card settings 

Disable the "Show Window Contents While Dragging" option 

Note If you do not have Microsoft Plus! for Windows 98 installed on your Windows 98-based computer, go 
to the "Reduce the number of colors that Windows uses" section. 
 
For Windows 98, follow these steps:  

1. Right-click the desktop, and then click Properties. 

2. On the Plus tab, clear the Show Window Contents While Dragging check box, and then click OK.

For Windows 98 Second Edition and Windows Millennium Edition, follow these steps:  

1. Right-click the desktop, and then click Properties. 

2. 
On the Effects tab, clear the Show Window Contents While Dragging check box, and then click 
OK. 

Reduce the number of colors that Windows uses 

In Windows 98, Windows 98 Second Edition, and Windows Millennium Edition, follow these steps:  

1. Right-click the desktop, and then click Properties. 

2. 
On the Settings tab, in the Colors box, click a setting that is less than the current setting, click OK, 
and then click Yes. 

Repeat this procedure until you can either no longer reproduce the error or until you are using the lowest 
color setting.  

Reduce the screen area 

In Windows 98, Windows 98 Second Edition, and Windows Millennium Edition, follow these steps:  

1. Right-click the desktop, and then click Properties. 

2. 
On the Settings tab, in the Screen Area box, move the Screen Area slider to a screen area that is 
lower than your current screen area setting, click OK, and then click Yes. 

Repeat this procedure until you can either no longer reproduce the error or until you are using the lowest 
resolution setting.  

Turn off hardware acceleration 

To turn off hardware acceleration, follow these steps:  

1. Right-click My Computer, and then click Properties. 

2. On the Performance tab, click Graphics. 

3. Move the Hardware Acceleration slider to None, click OK, click Close, and then click Yes. 

Turn off Active Desktop 

If you are running the Windows 98, use one of the following methods:  

• Click Start, point to Settings, click Active Desktop, and clear the View as Web Page check box.

• Right-click the desktop, click Active Desktop, and then clear View as Web Page check box. 



If you are running Windows Millennium Edition with either Internet Explorer 5.5 or Internet Explorer 6, 
use one of the following methods:  

• 
Right-click the desktop, click Properties, click the Web tab, clear the Show Web content on my 
Active Desktop check box, and then click OK. 

• 
Right-click the desktop, click Active Desktop, and then clear the Show Web Content on my Active 
Desktop check box. 

If your configuration is different from the configurations that are described earlier in this section, follow 
these steps:  

1. Right-click the desktop, and then click Properties. 

2. On the Web tab, clear the View my Active Desktop as a web page check box, and then click OK.

Note If any of the preceding sections resolve this issue, you may have to update the driver for your video 
adapter. For information about how to obtain an updated driver for your video adapter, contact the 
manufacturer of your video adapter or of your computer.  
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Install the current version of Microsoft DirectX 

For information about how to install the current version of Microsoft DirectX, visit the following Microsoft 
Web site:  
http://www.microsoft.com/directx/homeuser/downloads/default.asp 
(http://www.microsoft.com/directx/homeuser/downloads/default.asp) 
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APPLIES TO 

• Microsoft Internet Explorer 6.0, when used with: 

    Microsoft Windows Server 2003, Standard Edition (32-bit x86)

    Microsoft Windows XP Professional 

    Microsoft Windows 2000 Standard Edition 

    Microsoft Windows NT 4.0 Service Pack 6 

    Microsoft Windows Millennium Edition 

    Microsoft Windows 98 Second Edition 

    Microsoft Windows 98 Standard Edition  

• Microsoft Internet Explorer 5.5, when used with: 

    Microsoft Windows 2000 Standard Edition

    Microsoft Windows NT 4.0 

    Microsoft Windows Millennium Edition 

    Microsoft Windows 98 Second Edition 

    Microsoft Windows 98 Standard Edition 

    Microsoft Windows 95  

• Microsoft Internet Explorer 5.01, when used with: 

    Microsoft Windows 2000 Standard Edition



    Microsoft Windows NT 4.0 

    Microsoft Windows 98 Second Edition 

    Microsoft Windows 98 Standard Edition 

    Microsoft Windows 95  

• Microsoft Internet Explorer 5.0, when used with: 

    Microsoft Windows 2000 Standard Edition

    Microsoft Windows NT 4.0 

    Microsoft Windows 98 Second Edition 

    Microsoft Windows 98 Standard Edition 

    Microsoft Windows 95  
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